Support forum

Advanced Search

— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

SQL Connector sending Ussd messages.
sp_NewPost Add Reply sp_NewTopic Add Topic
August 12, 2014
12:47 am

Hi Henk,

I was able to resolve the problem creating a new database SQL Connector and created a new database and later changed the connect string on it to connect to the already existing database. Creating a new connector filled out all the information in message in and out tables and also in the advance settings, once I did this the application work fine. Because I tried to created an SQL Connector over an existing database base none of the fields where filled and not having the advance MessageType field correctly assigned that was why the problem I described manifested itself.

I don´t know why I lost the configuration of the original SQL Connector. I am investigating. I don't think it's a Diafaan issue.

Thank you very much for your quick response.


August 11, 2014
9:00 pm
Henk Helmantel
Forum Posts: 519
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Luis,

If you send the configuration file of your installation to, I will have a look to see what might be wrong. You can save the configuration file with the menu options 'File-Export-Configuration'.

Regards, Henk

August 11, 2014
3:27 am

Hi Henk,

I have been sending ussd messages using de SQL connector with SQL Server. Everything has been working fine until now. After loosing Internet from our services provider the SQL connector disappeard. I created another SQL Connector and now eventhough the "message type" field in the MessageOut table is set to "gsm.ussd" when I copy from the send message the errored record y get that the message was sent as "sms.automatic" and therefore giving me this error "Error: Invalid sms number: 106*1*72009144*12300*8699*1".

I have tried a lot of things but I cannot get the Diafaan server to recognized there records in the sql database as gsm.ussd

Please help!

Thank you

Luis Villar

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
11 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 354

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 511

Posts: 1772

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 519