Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

April 27, 2023
11:32 am
Henk Helmantel
Admin
Forum Posts: 1502
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Thank you for the configuration file.

In the advanced settings of the SMPP gateways you can find the setting 'MaxMessagesPerMinute', this is set to 600 messages per minute, or 10 messages per second, the default value. If you set this to a higher value the maximum throughput of the SMPP gateway will be increased.

There is a limit to the message throughput that Diafaan SMS Server can handle, this is not a fixed value but depends on the settings of the gateways and the specification of the computer, especially the speed of the hard disk.

Regards, Henk

April 27, 2023
9:55 am
Henk Helmantel
Admin
Forum Posts: 1502
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Lucky,

Can you send me the configuration file of Diafaan SMS Server (menu options 'File-Export-Configuration') so that I can have a look at your configuration? You can send the file to email address dms@diafaan.com.

Regards, Henk

April 26, 2023
11:00 pm
Lucky
Guest
Guests

Hi,

I'm trying to get to a throughput of around 100 sms/sec and it seems to be more of a problem than I expected.

I first tested sending using the HTTP API. Now I am creating messages using the command line. If I try to send around 3000 messages at a time, I see hundreds of messages in the queue, so I assume that the problem is not the speed of message creation but the speed of sending.

Authorization for HTTP is off.

I am unable to send more than 10 sms/sec/smpp gateway. If I add more of the same, I am always around 10 sms/sec/gateway. So I assume that the problem is not in the performance of the computer when I manage to scale the sending by adding gateways, but I don't know if this is the most efficient way. No changes in MaximumBatchSize or AsyncModeWindowSize settings seem to play a role (same result for 10 and 1 as for 60 and 20).

Any ideas on what to try next? I can add more cpu or ram, but right now it doesn't seem to have an effect.

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 529

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 677

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 1149

Posts: 3928

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 1502