Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
Problems decoding SMPP PDU's
sp_NewPost Add Reply sp_NewTopic Add Topic
May 2, 2012
10:49 am
Henk Helmantel
Guest
Guests

Hi Kjell,

Can you send me the log record of a failed message? To get the full log record, go to the Receive Log, right-click on one of the failed messages and select "Export to file". You can post the record here or send it to dms at diafaan dot com.

I have just tested a message with ÆØÅæøå characters and this is received without problem with the SMPP server we use so I presume that your SMPP server uses a different encoding for those characters.

Regards, Henk

May 2, 2012
12:05 am
Kjell
Guest
Guests

Sorry, some problems with the picture link. Added it to the first post.

May 2, 2012
12:04 am
Kjell
Guest
Guests

Hi

I am conducting a trial of your SMS basic server. My setup is an SMPP connection towards the SMSC provider, and a DB connector that stores all of the received messages in a database. The setup works fine, but a lot of received messages fail, with "Error decoding SMPP packet".

The SMPP packet validates OK in other SMPP API's etc.

I have narrowed it down to character issue. Your SMS server fails to decode when the message text contains one of these character's ÆØÅæøå. Se attached picture url if you cant see them.

picture

These are Norwegian characters and here's the ASCI codes:

145 = æ
146 = Æ
155 = ø
157 = Ø
134 = å
143 = Å

Have I missed something in my config?

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 365

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 533

Posts: 1849

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 554