Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
GSM Modem port keeps opening and closing
sp_NewPost Add Reply sp_NewTopic Add Topic
May 14, 2013
10:53 am
Henk Helmantel
Guest
Guests

Hello Tom,

Most Huawei USB modems create two virtual serial ports and normally Diafaan SMS Server either one. However, I have noticed that some Huawei USB modems hang when the "3G PC UI Interface" port is not used. This port generates status messages and it appears that the modem hangs after some time when these status messages are not handled.

Since your modem keeps working when you use the Huawei Mobile Partner program I suspect that in your case the Huawei Mobile Partner software intercepts the status messages and prevents the modem from hanging. If this is indeed the problem, you can use the other COM port of the Huawei modem in Diafaan SMS Server without the need to use the Huawei software.

If this does not solve the problem you can also change the settings in the Huawei Mobile Partner software to store the SMS messages in the SIM card instead of the Huawei software. But in that case you have to keep the Huawei Mobile Partner software open.

Regards, Henk

May 14, 2013
3:25 am
Tom
Guest
Guests

Hello,

I'm a user of the light edition. Using Huawei E1756C GSM Modem with SQL (MySQL) connector. Our application was working great on a windows 7 machine (64 bit). I recently moved it over to a windows server 2008 machine (64 bit) and we started seeing some issues. The GSM port constantly opens and close. I enabled logging to find a cause. Most of the log is gibberish to me, but I do see this line repeating in the log a few times: CMS ERROR: 303.

Strangely, if I open (and leave open) the software that comes with the GSM modem the port stays open in diafaan. I was sort-of OK with just leaving it open if it kept the port open. The problem is that Diafaan doesn't seem to receive messages if I have the software open, instead the software receives it. Diafaan can send messages without any issues however while that software if open.

Ideally I want it to behave like it did when I had it on the other machine...meaning that the modems software isn't open and Diafaan does all the work.

Let me know if there is a way to resolve my issue. Thanks.

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 364

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 532

Posts: 1844

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 551