Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
Email Connector not able to Connect
sp_NewPost Add Reply sp_NewTopic Add Topic
February 29, 2024
9:57 am
Henk Helmantel
Admin
Forum Posts: 1502
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

It will take a few days to create the plugin. I'll email it to you when it is ready.

Regards, Henk

February 28, 2024
3:59 pm
Sarfaraz
Guest
Guests

Hello Henk,

I don't see any other way, as we cannot do much with the ZOHO email. Please share the plugin so we can use the same and do the needful.

Thanks and have a great day!!!

February 28, 2024
3:52 pm
Henk Helmantel
Admin
Forum Posts: 1502
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Sarfaraz,

The POP3 server says that it supports AUTH PLAIN but does not accept the AUTH PLAIN command that Diafaan SMS Server sends to the POP3 server to log on. It does not give a clear reason for this except '-ERR ; invalid argument for auth'.

When authentication with AUTH PLAIN fails, Diafaan SMS Server tries to fall back to APOP and, when that fails, to basic authentication but before that can happen the POP3 server has already closed the connection.

It seems that the zoho.in POP3 server reports that it supports both AUTH PLAIN and APOP authentication but it rejects both authentication methods when Diafaan SMS Server uses them. Basic authentication (with the USER and PASSWORD commands) works so if there is no other way to get it to work I can send you a plugin for the Email Connector with an option to enforce basic authentication for POP3 connections. Please let me know if you want to receive this plugin.

Regards, Henk

February 27, 2024
2:31 pm
Sarfaraz
Guest
Guests

Hello Henk,

We are using the Diafaan SMS server - 4.3.02 on one of our servers. We are facing some issue with the email connector. Below are the error details can you please look into this and let us know.

2024/02/27 18:53:01.441 - Connecting to [*REMOVED*].
2024/02/27 18:53:01.441 - Connected, localEP='[*REMOVED*]'; remoteEP='[*REMOVED*]'.
2024/02/27 18:53:01.441 - Starting SSL handshake.
2024/02/27 18:53:01.458 - SSL handshake completed sucessfully.
2024/02/27 18:53:01.458 +OK POP3 mx.zoho.in v1.0 server ready
2024/02/27 18:53:01.458 CAPA
2024/02/27 18:53:01.458 +OK
2024/02/27 18:53:01.458 USER
2024/02/27 18:53:01.458 TOP
2024/02/27 18:53:01.458 UIDL
2024/02/27 18:53:01.458 SASL PLAIN
2024/02/27 18:53:01.458 AUTH PLAIN [*REMOVED*]
2024/02/27 18:56:11.102 APOP [*REMOVED*]
2024/02/27 18:56:11.102 - Remote host closed connection.
2024/02/27 18:56:11.102 - POP3 Client exception: Object reference not set to an instance of an object.
2024/02/27 18:56:11.102 USER [*REMOVED*]
2024/02/27 18:56:11.102 - Remote host closed connection.
2024/02/27 18:56:11.102 - POP3 Client exception: Object reference not set to an instance of an object.
2024/02/27 18:56:11.102 QUIT
2024/02/27 18:56:11.102 - Disconnected.

September 23, 2022
10:22 am
Sarfaraz
Guest
Guests

Hello Henk,

Thank you so much for quick assistance. Now it is working as expect. You were right the test option doesn't not connect but once you save the settings it works fine.

Thanks again for always being there and resolving our issues.

Thanks
Sarfaraz

September 23, 2022
9:48 am
Henk Helmantel
Admin
Forum Posts: 1502
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Sarfaraz,

If the username and password are correct, the POP3 client will work fine after you finish the setup for the Email Connector.

The test procedure for the POP3 client is not entirely the same as the normal login procedure, that is the reason why the POP3 client is not able to log on to the POP server in the test. In the normal operation, the POP3 client will try log on in plain text after the APOP login is not successful and if the username and password is correct, plain text login will work for the zoho.in POP3 server.

Regards, Henk

September 22, 2022
7:16 pm
Sarfaraz
Guest
Guests

Hello Henk,

Hope you are doing well.

We have a customer who have given us the ZOHO email pop3 setting. When we try to connect to that we are getting the below error. Can you please suggest what is could be the issue.

poppro.zoho.in
995
SSL
Username and Password

We are getting the below error.
Connecting to 103.103.197.102:995.
Connected, localEP='10.0.0.6:62794'; remoteEP='103.103.197.102:995'.
Starting SSL handshake.
SSL handshake completed sucessfully.
+OK POP3 mx.zoho.in v1.0 server ready
CAPA
+OK
USER
TOP
UIDL
.
APOP
-ERR command not supported
-ERR command not supported

Can you please help us on this.

Thanks
Have a great day!!!

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 529

Currently Online:
1 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 677

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 1149

Posts: 3928

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 1502