Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
e173 modem anomalies
sp_NewPost Add Reply sp_NewTopic Add Topic
February 12, 2014
9:21 am
Henk Helmantel
Admin
Forum Posts: 553
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Error 500 is a general device specific error, the cause of the error is unknown and it just means that the messages could not be sent. This error has nothing to do with the problems in your first post. The Huawei E173 works fine but for some reason it just can't send the message.

Since the type of error is unclear, there is very little that you can do about it. It might be that the signal quality of the GSM network is too low but it is also possible that the GSM network rejects the messages or that there is an internal clash of incoming and outgoing messages that cause the problem. If the errors are sporadic then it is not really a big problem but if there are too many errors it is probably better to try a different GSM modem.

One thing you could try is to set the 'RebootBeforeInitialization' option to 'True' in the advanced settings of the GSM Modem Gateway properties. This sometimes solves this kind of problems but it does not always work properly with USB modems.

Regards, Henk

February 12, 2014
2:13 am
nick
Guest
Guests

I decreased the sending speed as suggested but errors were coming thick and fast so I put it back to 0. Now fewer errors and ofa different type;

"The GSM Modem returned +CMS ERROR: 500 (Unknown error) after the 079144978578899771950C914447437358570010AA090500033103038E4C command."

Is this is a similar error to the previous one I reported (my first post) ?

February 11, 2014
10:24 am
Henk Helmantel
Admin
Forum Posts: 553
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

The error means that the GSM modem did not respond after Diafaan SMS Server tries to send the message. This is usually an indication that the modem is temporary busy, for instance when a message is received from the GSM network at the same time.

Sometimes it helps if you decrease the sending speed the messages, you can do that by increasing the 'SendDelayTime' property in the advanced settings of the GSM Modem Gateway. However, even with decreased send speed it is not unusual to get this error every now and then.

I am afraid that I am not able to give you advise about the firmware upgrade of your modem.

Regards, Henk

February 10, 2014
8:51 pm
nick
Guest
Guests

Thank you for your reply Henk.
I found two com ports on the E173 so I used the other one along with AT^CURC=0. Working much better now but has reported a different error on just 3 occasions. The error this time is :
Timeout error, no or unexpected response after GSM Modem command "0791449785788997313804B072230000AA03C22013".
Does that mean anything to you ?
As to the firmware upgrade, I upgraded one of two E173's I had. In doing so one E173 is now a M6920 and doesn't work anymore. Have you come across this occurrence ? I take it we cannot go backwards !!!

February 9, 2014
1:48 pm
Henk Helmantel
Admin
Forum Posts: 553
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Nick,

This type of behavior is usually an issue with the driver or firmware of the GSM modem, it might be necessary to update the driver software and firmware to the latest versions to solve this problem.

There are a couple of other options you can try first, most Huawei GSM modems have two serial ports and I have noticed that on some models the modem stops working after some time when it is connected to the "wrong" COM port. You can to connect Diafaan SMS Server to the other port and see what happens.

Another way to solve the same problem is to set the 'ModemInitializationBeginning' parameter in the advanced settings of the GSM Modem Gateway to 'AT^CURC=0'. This disables the diagnostics reporting on the serial port that seems to be the cause of the problem.

You can check if the link in your post has anything to do with your problem by setting the GSM Modem Gateway to 'Send only', this disables the +CMGL commands that causes the problems described in the link.

Regards. Henk

February 9, 2014
12:17 pm
nick
Guest
Guests

re: my post of a few minutes ago. Came across this http://comments.gmane.org/gmane.linux.drivers.gammu/9690
Might this be of any help ?

February 9, 2014
12:12 pm
nick
Guest
Guests

using E173. Works for an hour or so then com port is forever opening and closing so unable to receive or send sms. Please see below. Have also setup a sony mobile phone and there are no problems. PS. 12 is the name of the gateway which corresponds to the com port number

EventTime Event Source
09/02/2014 11:04:22 Serial port "COM12:115200,n,8,1" open. 12
09/02/2014 11:04:22 Serial port closed. 12
09/02/2014 11:03:51 Serial port "COM12:115200,n,8,1" open. 12
09/02/2014 11:03:50 Serial port closed. 12
09/02/2014 11:03:19 Serial port "COM12:115200,n,8,1" open. 12
09/02/2014 11:03:19 Serial port closed. 12
09/02/2014 11:02:48 Serial port "COM12:115200,n,8,1" open. 12
09/02/2014 11:02:47 Serial port closed. 12
09/02/2014 11:02:47 Reset modem connection. 12
09/02/2014 11:02:47 Timeout error, no or unexpected response after GSM Modem command "AT+CMGL=4". 12
09/02/2014 11:02:16 Serial port "COM12:115200,n,8,1" open. 12

Your help please on how to overcome above

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 364

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 532

Posts: 1847

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 553