Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
Data returned on MessageLog
sp_NewPost Add Reply sp_NewTopic Add Topic
February 18, 2020
4:07 pm
Henk Helmantel
Admin
Forum Posts: 1203
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Thank you for the configuration file.

Your configuration does not have any SQL Connectors so I don't understand were the SQL queries in your post are coming from. Can you specify where the INSERT commands are coming from and send me the corresponding log file(s)?

Regards, Henk

February 17, 2020
3:34 pm
Henk Helmantel
Admin
Forum Posts: 1203
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Blubsy,

Can you send me the configuration file of Diafaan SMS Server (menu options 'File-Export-Configuration')? Your log lines of the SQL Connector suggests that you are using more than one SQL Connector and I would like to see the configuration file to see how Diafaan SMS Server is set up. You can send the file to email address dms@diafaan.com.

Regards, Henk

February 16, 2020
10:12 pm
blubsy
Guest
Guests

Hello,
I am currently setting up my website and Diafaan, but I have a problem with the return on MessageLog.
Diafaan is well connected to my site by OCDB.
It retrieves data well and modifies data (read).
But when it saves the data in MessageLog, it only saves certain data (smpp gateway):
 INSERT INTO MessageLog (SendTime, MessageTo, MessageText, MessageId, StatusCode) VALUES (?,?,?,?,?)
(info log Diafaan).

When I test on another gateway (http), it sends me back:
INSERT INTO MessageLog (SendTime, MessageFrom, MessageTo, MessageText, MessageType, MessageId, StatusCode, Gateway, MessagePDU, StatusText, ErrorCode, ErrorText, UserId, UserInfo, MessageGuid, MessageInfo, Connector, MessageParts) VALUES (?,?,?,?, ?,?,?,?,?,?,?,?,?,?,?,?,?,?)

I need his data to track logs on my site.

Another question :
I add parameters
SMSOutUserId -> User_id
and
SMSLogUserId -> UserId
Diafaan is sending me a lot of data but I always have "0" in MessageLog.
Where is the problem ?

Thanks for all your help.

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 582

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 954

Posts: 3280

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 1203