Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
CMS: 111 Error intermittently
sp_NewPost Add Reply sp_NewTopic Add Topic
November 13, 2022
10:52 am
Henk Helmantel
Admin
Forum Posts: 1502
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Aaron,

The best way to find out what happens is to enable communication logging for the GSM Modem Gateway and check the log file for errors.

I suspect that there are a lot of send errors in the communication log. This would explain the difference between sending messages from the 'Send message' page in the console program and sending them through the connector. When you send a test message from the console program, Diafaan SMS Server only makes one send attempt and when that fails it reports it as such in the send log. Messages that are sent through one the connectors are sent up to three times in the default settings before they are marked as failed in the send log.

It is difficult to say what the exact cause of the problem is but if the problem suddenly occurs it is often caused by a change in the mobile network, for instance a network update or a change in the antenna arrangement. It could also be caused by a change in the anti-spam policy of the provider.

Regards, Henk

November 10, 2022
7:34 pm
Aaron D
Guest
Guests

To start this off I will describe our system:
Modem: MultiTech MTC-LNA4-B01-US
Carrier: T-mobile GSM
Gateway: GSM Modem Gateway
Connector: Web Connector
Feed to Connector: Extended Stored Procedure in SQL Server 2019 that calls a SQL server function that contains a c# web service call to the Web Connector

This setup has been working well for several years now. It was at the end of October 2022 that complaints of SMS not going through came in to us. Sending a message directly from the Diafaan test page even was failing almost always and same through our more elaborate system. T-mobile had us replace the sim card which seemed to eliminate a lot of the errors. Also found one canned messaged that was over character limit so reduced that reducing them further.

The issue is inconsistently to any phone number we are still occasionally getting CMS 111 errors. I have confirmed reboot on error is turned off as prior notes of original setup just in case it was taking too long to talk to T-mobile again. I have successfully sent a text using direct AT commands to the modem. So I am trying to get some ideas of what to check or try next so that texts consistently go through.

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 529

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 678

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 1149

Posts: 3929

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 1502