Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
SQL Database error - MessageLog table
sp_NewPost Add Reply sp_NewTopic Add Topic
August 7, 2017
3:33 pm
Henk Helmantel
Admin
Forum Posts: 698
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Ibrahim,

The most likely cause of this problem is that there is an issue with one of the database fields in the MessageLog table. I can only repeat the advice I gave in the post that you referred to:

If this error is consistent then there probably is an issue with the layout of the 'MessageOut' database table that you use. To see what happens you can enable the communication logging in the SQL Connector by setting the 'LogCommunicationToFile' property in the advanced settings of the SQL Connector to 'True'. Don't forget to turn off logging after you finished the tests.
The log probably shows a difference in the number of records that are read from the 'MessageOut' table and the number of records that are removed from the table subsequently. If that happens, the SQL Connector rolls back the transaction to make sure that messages are not sent over and over again.
The exact solution for the problem depends on what the issue is with the database table layout but if you look at the logs it should be possible to find out what the problem could be.

Regards, Henk

August 7, 2017
12:05 pm
Ibrahim
Guest
Guests

Hello Henk
i am using the trial basic edition with an SMPP and sql connector.
it works perfectly except the messagelog table is not updating the statues of the sent messages.

it always shows 200 in the statuscode column , Doesn't update even if i waited for a day or two , i tried setting MessageLogRetryOnError to true but that doesn't help.

if i restart the sql connector it shows this error :

SQL Database error, the status of 25 messages could not be updated in the MessageLog table and are removed.

i searched the forum and found this post but the guy wondered off to another error ,
https://www.diafaan.com/support-forum/using-diafaan-sms-server/sql-database-error/

can you tell me what steps i should take to diagnose the problem ,
Thank you

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
2 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 421

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 629

Posts: 2154

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 698