Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
Same message is getting repeatedly receiving in Receiving Log
sp_NewPost Add Reply sp_NewTopic Add Topic
November 22, 2012
6:45 am
ASHOK GUDURU
Guest
Guests

Henk,

I tired all of the modem init strings mentioned by you. Thay didn't work well. Some stopped initializing, others stopped sending. some more stopped receiving. others the problem remained same.
I tried playing several combinations of them and finally I figured out that the following init string seems working fine for T700.

AT+CPMS="SM","MT","SM"

Thanks
Ashok

Henk Helmantel said

I saw from the logs that the problem receiving messages repeatedly was solved with the initialization string:
AT+CPMS="SM","SM","SM

With regard to the problem with sending messages: You are sending the messages to a 3-digit short code, Diafaan uses the address type "Network specific" for short codes and not all GSM operators accept this address type. Some GSM operators require shortcodes to be sent with address type "Unknown".

You can force Diafaan SMS Server to use another address type by adding a prefix to the short code number. Diafaan SMS Server supports three prefixes:

"+" International number (e.g. +919989923***)
"#" National number (e.g. #09989923***)
"*" Unknown address type (e.g. *121)

Regards, Henk

November 14, 2012
10:28 am
Henk Helmantel
Guest
Guests

I saw from the logs that the problem receiving messages repeatedly was solved with the initialization string:
AT+CPMS="SM","SM","SM

With regard to the problem with sending messages: You are sending the messages to a 3-digit short code, Diafaan uses the address type "Network specific" for short codes and not all GSM operators accept this address type. Some GSM operators require shortcodes to be sent with address type "Unknown".

You can force Diafaan SMS Server to use another address type by adding a prefix to the short code number. Diafaan SMS Server supports three prefixes:

"+" International number (e.g. +919989923***)
"#" National number (e.g. #09989923***)
"*" Unknown address type (e.g. *121)

Regards, Henk

November 14, 2012
6:29 am
ASHOK GUDURU
Guest
Guests

I sen the the logs to your mail

Thanks
Ashok

Henk Helmantel said

Hi Ashok,

The logs that you have sent me does not show a message send attempt. Can you send me a log where you send a message with the modem?

Regards, Henk

November 13, 2012
8:01 pm
Henk Helmantel
Guest
Guests

Hi Ashok,

The logs that you have sent me does not show a message send attempt. Can you send me a log where you send a message with the modem?

Regards, Henk

November 13, 2012
4:45 pm
ASHOK GUDURU
Guest
Guests

Henk,

I'll try these init strings.

I also have problem of sending SMS using Diafaan. When I try sending an SMS I'm getting the following error.
300, Error: Unknown error after PDU sent.

I know the T700 doesn't be a full featured modem. but the same T700 is working fine with 'SMS Reception Center' software.
Through this software, the T700 is working fine. I'v some other problems with this software for my prototype like reset every 15 mins. etc.

Do you have any config for this?

Thanks for the support.
Ashok

Henk Helmantel said

Thank you for the logs. Can you try to use one of the following modem commands in the "ModemInitialization" property of the Advanced settings of the GSM Modem Gateway:

AT+CPMS="ME","ME","ME"
or
AT+CPMS="MT","MT","MT"
or
AT+CPMS="SM","SM","SM"

I am not sure which one is the correct command for the Sony Ericsson T700 but I think the first one should solve the problem.

Regards, Henk

November 12, 2012
9:45 am
Henk Helmantel
Guest
Guests

Thank you for the logs. Can you try to use one of the following modem commands in the "ModemInitialization" property of the Advanced settings of the GSM Modem Gateway:

AT+CPMS="ME","ME","ME"
or
AT+CPMS="MT","MT","MT"
or
AT+CPMS="SM","SM","SM"

I am not sure which one is the correct command for the Sony Ericsson T700 but I think the first one should solve the problem.

Regards, Henk

November 12, 2012
8:12 am
ASHOK GUDURU
Guest
Guests

Thanks Henk,

Yes what you said is correct that it is not fully capable modem for server. I'm trying to develop one application for which I need a server like diafaan, I'm experimenting now on how it is working. For my use, I need to develop a small prototype of my application that I need to demonstrate to my party. That's why I'm using diafaan and T700 now. Once I see the capability we'll go for a full model pool.

I'm sending the log file as you requested.

Thanks for the reply.
Ashok

Henk Helmantel said

Hi Ashok,

Can you send the communication log for the modem to dms@diafaan.com? See http://www.diafaan.com/how-to/log-modem-problems/ on how to create the communication log.

I recommend to use only dedicated GSM modems for use with Diafaan SMS Server. Serial port modems or TCP/IP or USB modem pools are optimal for non-supervised systems and USB dongles can be used for systems that do not require high reliability. Smartphones usually don't work very well and older GSM phones can be used but often also have reliability issues. The Sony Ericsson T700 is not really a smartphone but it is not unlikely that the SMS application in the phone messes things up.

Regards, Henk

November 11, 2012
2:21 pm
Henk Helmantel
Guest
Guests

Hi Ashok,

Can you send the communication log for the modem to dms@diafaan.com? See http://www.diafaan.com/how-to/log-modem-problems/ on how to create the communication log.

I recommend to use only dedicated GSM modems for use with Diafaan SMS Server. Serial port modems or TCP/IP or USB modem pools are optimal for non-supervised systems and USB dongles can be used for systems that do not require high reliability. Smartphones usually don't work very well and older GSM phones can be used but often also have reliability issues. The Sony Ericsson T700 is not really a smartphone but it is not unlikely that the SMS application in the phone messes things up.

Regards, Henk

November 11, 2012
6:16 am
ASHOK GUDURU
Guest
Guests

Hi,

I'm getting same message receiving into Diafaan SMS Receiving. Its continually receiving same newly arrived message.

The receving log shows that the message is part is received.

I'm using my Sony Ericsson T700 to my laptop. I'm using latest drivers & pc-suite that's come with my phone.

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 364

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 532

Posts: 1847

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 553