Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
installing 8 port USB modem Pool
sp_NewPost Add Reply sp_NewTopic Add Topic
October 1, 2014
10:51 am
Henk Helmantel
Admin
Forum Posts: 552
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

I am glad it works but I have no idea why the serial port settings for the modem are different on different GSM networks.

Normally, the serial port settings are properties of the GSM modem device and not dependent on the SIM card that is used.

Regards, Henk

October 1, 2014
1:57 am
Luis Villar
Guest
Guests

Hi Henk,

There are 3 mayor operators the ICE the largest when I tried XonXoff like you suggested it actually worked. with Claro and Movistar they work on "RequestToSend"

right now it is working as described above.

Thank you

Luis

September 30, 2014
10:12 am
Henk Helmantel
Admin
Forum Posts: 552
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Can you try what happens when you add the GSM Modem Gateway for one of the modem ports (ignore the error when you use the Test button) and afterwards set the 'FlowControl' property in the advanced settings of the newly created GSM Modem Gateway to 'XonXoff'?

If it still does not work with the 'XonXoff' setting, I would like to see the communication log for the GSM Modem Gateway. You can send the communication log to dms@diafaan.com.

Regards, Henk

September 29, 2014
5:32 pm
Luis Villar
Guest
Guests

By the way,

AT+CGMI returns inmediately

SIMCOM INCORPARATED

Thanks,

Luis

September 29, 2014
5:29 pm
Luis Villar
Guest
Guests

Hi Henk,

this is the event log in putty
2014-09-29 09:23:56 Opening serial device COM10
2014-09-29 09:23:56 Configuring baud rate 115200
2014-09-29 09:23:56 Configuring 8 data bits
2014-09-29 09:23:56 Configuring 1 data bits
2014-09-29 09:23:56 Configuring no parity
2014-09-29 09:23:56 Configuring XON/XOFF flow control

And the command 'AT+CGMM' returns the folloning inmediatealy

SIMCOM_SIM5215A

Thanks,

Luis

September 27, 2014
2:38 pm
Henk Helmantel
Admin
Forum Posts: 552
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

Hello Luis,

I am not familiar with the SIMCOM SIM5215A modem module but I have tested other SIMCOM modules that worked well with Diafaan SMS Server.

It is unlikely that the SIM card is the cause of this problem. My first thought is that the problem might be caused by the virtual serial port of the Bailing modem pool. Can you try to open one of the COM ports with a terminal program like PuTTY and let me know what the modem responds to the 'AT+CGMM' command?

Regards, Henk

September 27, 2014
12:04 am
Luis Villar
Guest
Guests

Hi Henk

I purchased a SIMCOM IMCORPORATED model SIMCOM_SIM5215A 8 modem Pool from Bailing in China.

The Diafaan server recogonizes de MODEMS but when I TEST the modem I get

- Open port: COM9:115200,n,8,1
> AT&FE0

AT+CGMI

- Timeout
- Port closed

and the modem never initializes. this with an ICE sim card, I tried with a Claro card and it did test OK but the gateway soon disabled and gives me the same message on test.

Any suggestiones as to what to try or find out about the modems.

thank you

Luis Villar

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 364

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 532

Posts: 1845

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 552