Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
'EmulatorGateway' plugin not found
sp_NewPost Add Reply sp_NewTopic Add Topic
March 17, 2013
10:57 pm
Eric van Doorn
Guest
Guests

I reverted to an earlier snapshot of the server (it's on VMware) and did a fresh install of the SMS server from the start. The emulator gateway is working great now. Don't know what I did wrong earlier. Anyway, thanks a lot for your help.

Regards, Eric

March 17, 2013
5:06 pm
Henk Helmantel
Guest
Guests

The plugin works with the trial version of Diafaan SMS Server and it also works on the 64 bit version of Windows Server 2008, that is not the problem.

I suspect that there is a problem with the file permissions for the EmulatorGateway.dll file that prevents the Diafaan SMS Server service to access the file. The console program seems to have the proper permissions to load the file and that is why you can see the Emulator Gateway in the console program.

There are two ways you can solve this problem, first by changing the security permissions for the EmulatorGateway.dll file. Or you can set the logon parameters for the Diafaan SMS Server service in the Windows Service Control Manager to an account with more privileges. The default account is the local system account, you can change that to your own Windows account or to an administrator account.

Regards, Henk

March 17, 2013
1:46 pm
Eric van Doorn
Guest
Guests

Hi Henk,

Thanks for the reply. I tried restarting the service and restarting the PC, but with the same result. I'm running on Windows server 2008 R2 x64, could the issue be related to that? Another possibility could be that I have installed the trial version while waiting fore acquisition of a license (this will take a few days). Maybe the emulator is blocked because of a missing license?

best regards,
Eric

March 17, 2013
11:23 am
Henk Helmantel
Guest
Guests

Hello Eric,

This error means that the Diafaan SMS Server service did not yet load the plugin. To enable the Emulator Gateway plugin, you'll have to stop and start the service in the console program or in the Windows Service Control Manager.

You can also reboot the PC or server, the plugin is automatically loaded when the PC starts up.

Regards, Henk

March 17, 2013
10:29 am
Eric van Doorn
Guest
Guests

When I add the EmulatorPlugin.dll file to the plugins folder as described in the readme.txt the console enables me to add such a gateway. Unfortunately, after that it shows up with a red cross in the console and the status shows the message: 'EmulatorGateway' plugin not found. Also, the Send Message tab shows a red cross.

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
12 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 364

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 532

Posts: 1847

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 553