Support forum

Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_TopicIcon
ADD modem GATEWAY-HUAWEI E3531i
sp_NewPost Add Reply sp_NewTopic Add Topic
May 11, 2017
4:30 pm
Henk Helmantel
Admin
Forum Posts: 667
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

It is very unlikely that we will add support for HiLink modems in Diafaan SMS Server. In theory it would be possible but Huawei seems to actively discourage access to the HiLink modems from external software like Diafaan SMS Server. Huawei does not publish the technical requirements to access the HiLink modems and they regularly change the access procedure, making it almost impossible to write software that works reliably with these modems.

Regards, Henk

May 10, 2017
10:37 am
MUCHIRI DANIEL
Guest
Guests

Thank You Henk for the information,
I really hope Diaffan will find a workaround on this in the near future. Most of my clients have the Hilink modems and i really am stuck on how best i can assist them since we seem not to get older modem versions in the market.

May 10, 2017
10:20 am
Henk Helmantel
Admin
Forum Posts: 667
Member Since:
May 28, 2013
sp_UserOfflineSmall Offline

The Huawei E3531 is one of the Huawei HiLink line of modems and unfortunately these models are not compatible with Diafaan SMS Server.

Diafaan SMS Server can work with all GSM modems that support the GSM 07.05 / 07.07 AT command standard over a (virtual) serial port or TCP/IP connection. Most WiFi modems and the HiLink modems do not support this standard and do not have the ability to send and receive SMS messages from external applications like Diafaan SMS Server.

Regards, Henk

May 9, 2017
12:04 pm
MUCHIRI DANIEL
Guest
Guests

Hello,
I am not able to add SMS gateway on Diaffan. I am using Huawei E3531 modem and it is not being detected when i select TCP/IP. I am connecting on my local machine hence am using 127.0.0.1 as IP and port i am using the default: 23. Kindly assist. are my parameters correct?

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 494

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 415

Members: 0

Moderators: 0

Admins: 1

Forum Stats:

Groups: 2

Forums: 3

Topics: 610

Posts: 2091

Newest Members:

, Henk Helmantel

Administrators: Henk Helmantel: 667